Important release notes Important release notes

Notes on latest Condor(-emi) 7.8.8/7.8.7 update affecting WMS

Please pay attention that the latest version of Condor(-emi) available in the EMI 3 third-party repositories (7.8.8/7.8.7) require extra steps after the update in order to have a working WMS:
  • ...

List of updates List of updates

Update 22 (10.11.2014) - v. 3.13.0-1

The Update contains:

  • minor releases of APEL Parsers, v. 2.4.0 & APEL Publisher 4.3.0 (APEL 1.3.1-1), VOMS-admin server v. 3.3.1
  • revision release of dCache server v. 2.6.35, DPM/LFC, v. 1.8.9, glite-proxyrenewal v. 1.3.36, VOMS clients v. 3.0.5 & native 2.0.12-2 , VOMS Java APIs, v. 3.0.4, VOMS server, v. 2.0.12
  • repackage release of WMS, v. 3.6.6-2

 

 

APEL Parsers, v. 2.4.0 & APEL Publisher 4.3.0 (APEL 1.3.1-1)

Affected services

  • affected service: CREAM

What's new:

  • Corrected the handling of multiple FQANs in blah logs so that the role and group are taken from the first (i.e. primary) FQAN rather than the last. This will impact the summarising of job records when there are multiple roles and groups listed.
  • Fixed a crash that occurred when the parser encountered an empty file.
  • Added support for parsing fractional seconds in XML usage records.
  • Fixed database loader crash when save_messages was set to false.
  • Added options to unloader.conf to allow the unloader to unload more than just the current and previous months.
  • Added support for APEL servers to be sent normalised summaries using the new summary job record format (v0.3).
  • Some views used by the central APEL server, which shouldn't be needed by regional servers, have been separated out into server-extra.sql.

 

Installation & Configuration:

Known Issues

  • Parser not yet compatible with new version of Univa Grid Engine (version 8.2.0) which now reports time in milliseconds instead of seconds.

Artifacts

SL5
Binaries
apel-client-1.3.1-1.el5.noarch.rpm
apel-lib-1.3.1-1.el5.noarch.rpm
apel-parsers-1.3.1-1.el5.noarch.rpm
apel-server-1.3.1-1.el5.noarch.rpm
Source RPM
apel-1.3.1-1.el5.src.rpm
SL6
Binaries
apel-client-1.3.1-1.el6.noarch.rpm
apel-lib-1.3.1-1.el6.noarch.rpm
apel-parsers-1.3.1-1.el6.noarch.rpm
apel-server-1.3.1-1.el6.noarch.rpm
Source RPM
apel-1.3.1-1.el6.src.rpm

 

dCache server v. 2.6.35

Affected services

  • affected service: dCache server

What's new:

  • dCache server, v. 2.6.35
    • FIXES AFFECTING MULTIPLE SERVICES
      • The nfs and srm both cache replies from gPlazma to increase the speed of authenticating and identifying the user. Previously transient errors when communicating with gPlazma were also cached, delaying the recovery time from such errors. Now, such errors are not cached.
    • NFS
      • No longer trigger an NullPointerException when opening the .(parent)() dot-command file in Chimera's root directory.
    • POOL
      • Fix xrootd support for vector read. The problem was discovered with ROOT v6, which reports errors like Single readv transfer is too large.
    • XROOTD
      • Fix problems when calculating a response to the kXR_set request. If encountered, the problem results in the following being logged, where nnn in xrootd-disk-nnn is some integer number:
    • Uncaught exception in thread xrootd-disk-nnn java.lang.IllegalStateException: null
    • For more details see dCache server 2.6.35 - Extended Release Notes

Installation & Configuration

  • Please notice that due to the change to jpnfs-0.0.5, all NFS clients (v3 and v4) have to unmount prior update.
  • Please read the preliminary version of the Ultimate Golden Release Upgrade Guide carefully.

Artifacts

SL5
Binaries
dcache-2.6.35-1.noarch.rpm
SL6
Binaries
dcache-2.6.35-1.noarch.rpm
Deb6 Binaries
dcache_2.6.35-1_all.deb

 

DPM/LFC, v. 1.8.9

Affected Services

  • affected services: DPM, LFC, UI, WN

What's new:

  • Bird's view:
    • dmlite 0.7: Includes mysql, config, profiler, memcache, adapter dpm-dsi 1.9.3 dpm-xrootd 3.3.6 webdav 0.15 lcgdm 1.8.9
  • Highlights:
    • Extensive Logging Consolidation effort in the core components, the source structure, and the test infrastructure
    • Stable, continuous stress testing on the CERN testbeds (LAN) and performance regression monitoring
    • Stable, continuous performance/stability testing towards the Collaboration testbeds (WAN)
    • Several high impact performance improvements in the core components In-memory caching of pool/fs info in DMLite adapter
    • Bye bye YAIM, welcome Puppet
    • Realtime multiprotocol monitoring Xrootd-like
    • Reduce the time each MySQL conn is held (means less connections used)
    • Memcache improvements, local memory caching of always-accessed information dpm-listspaces
    • Glue2 additions and fixes to the calculations LCGDM core: little fixes Released the ARGUS poller to EMI3
  • For more details see DPM 1.8.9 - Extended Release Notes

Installation & Configuration

  • yum update

Known issues:

  • N/A

List of RfC

Artifacts

SL5
Binaries
emi-dpm_disk-1.8.9-1.el5.centos.x86_64.rpm
emi-dpm_mysql-1.8.9-1.el5.centos.x86_64.rpm
emi-lfc_oracle-1.8.9-1.el5.centos.x86_64.rpm
emi-lfc_mysql-1.8.9-1.el5.centos.x86_64.rpm
SL6
Binaries
emi-dpm_disk-1.8.9-1.el6.x86_64.rpm
emi-dpm_mysql-1.8.9-1.el6.x86_64.rpm
emi-lfc_oracle-1.8.9-1.el6.x86_64.rpm
emi-lfc_mysql-1.8.9-1.el6.x86_64.rpm

 

glite-proxyrenewal v. 1.3.36

Affected Services

  • affected services: glite-PX, WMS

What's new:

  • This is a rebuild of ProxyRenewal with the new major version of MyProxy (v. 6). There were updated manual pages. This revision also introduces packaging updates to better follow existing packaging guidelines, and missing runtime dependency on psmisc were added.

Deployment

  • Upon update, restart the ProxyRenewal daemon by calling /etc/init.d/glite-proxy-renewald restart.

Known Issues:

  • 32-bit packages are available but the metapackage won't install due to missing bdii or dependencies thereof, respectively. It is still possible to install 32-bit proxyrenewal and perform yaim-less configuration.

Artifacts

SL5
x86_64 Binaries
Binaries
emi-px-1.0.4-1.el5.x86_64.rpm
glite-px-myproxy-yaim-4.1.16-1.el5.noarch.rpm
glite-px-proxyrenewal-1.3.36-1.el5.x86_64.rpm
glite-px-proxyrenewal-debuginfo-1.3.36-1.el5.x86_64.rpm
glite-px-proxyrenewal-devel-1.3.36-1.el5.x86_64.rpm
glite-px-proxyrenewal-libs-1.3.36-1.el5.x86_64.rpm
glite-px-proxyrenewal-progs-1.3.36-1.el5.x86_64.rpm
i386 Binaries
emi-px-1.0.4-1.el5.i386.rpm
glite-px-myproxy-yaim-4.1.16-1.el5.noarch.rpm
glite-px-proxyrenewal-1.3.36-1.el5.i386.rpm
glite-px-proxyrenewal-debuginfo-1.3.36-1.el5.i386.rpm
glite-px-proxyrenewal-devel-1.3.36-1.el5.i386.rpm
glite-px-proxyrenewal-libs-1.3.36-1.el5.i386.rpm
glite-px-proxyrenewal-progs-1.3.36-1.el5.i386.rpm
Source RPM
emi-px-1.0.3-1.el5.src.rpm
glite-px-myproxy-yaim-4.1.16-1.el5.src.rpm
glite-px-proxyrenewal-1.3.36-1.el5.src.rpm
SL6
x86_64 Binaries
emi-px-1.0.4-1.el6.x86_64.rpm
glite-px-myproxy-yaim-4.1.16-1.el6.noarch.rpm
glite-px-proxyrenewal-1.3.36-1.el6.x86_64.rpm
glite-px-proxyrenewal-debuginfo-1.3.36-1.el6.x86_64.rpm
glite-px-proxyrenewal-devel-1.3.36-1.el6.x86_64.rpm
glite-px-proxyrenewal-libs-1.3.36-1.el6.x86_64.rpm
glite-px-proxyrenewal-progs-1.3.36-1.el6.x86_64.rpm
i386 Binaries
emi-px-1.0.4-1.el6.i686.rpm
glite-px-myproxy-yaim-4.1.16-1.el6.noarch.rpm
glite-px-proxyrenewal-1.3.36-1.el6.i686.rpm
glite-px-proxyrenewal-debuginfo-1.3.36-1.el6.i686.rpm
glite-px-proxyrenewal-devel-1.3.36-1.el6.i686.rpm
glite-px-proxyrenewal-libs-1.3.36-1.el6.i686.rpm
glite-px-proxyrenewal-progs-1.3.36-1.el6.i686.rpm
Source RPM
emi-px-1.0.4-1.el6.src.rpm
glite-px-myproxy-yaim-4.1.16-1.el6.src.rpm
glite-px-proxyrenewal-1.3.36-1.el6.src.rpm
Deb6 Binaries
emi-px_1.0.3-1_amd64.deb
glite-px-proxyrenewal-progs-dbg_1.3.36-1_amd64.deb
glite-px-proxyrenewal-progs_1.3.36-1_amd64.deb
glite-px-proxyrenewal_1.3.36-1_amd64.deb
libglite-security-proxyrenewal-dev_1.3.36-1_amd64.deb
libglite-security-proxyrenewal1-dbg_1.3.36-1_amd64.deb
libglite-security-proxyrenewal1_1.3.36-1_amd64.deb
Deb6 Sources
emi-px_1.0.4-1.debian.tar.gz
emi-px_1.0.4-1.dsc
emi-px_1.0.4.orig.tar.gz
glite-px-proxyrenewal_1.3.36-1.debian.tar.gz
glite-px-proxyrenewal_1.3.36-1.dsc
glite-px-proxyrenewal_1.3.36.orig.tar.gz

 

VOMS clients v. 3.0.5 & native 2.0.12-2 , VOMS Java APIs, v. 3.0.4

Affected services

  • affected services: CREAM, UI, WN, STORM, VOMS

What's new:

  • VOMS Clients 3.0.5 provide a new packaging which can coexist with the native, 2.0.12 clients (also released today). The new packaging of both packages allows the installer to choose which client should take precedence using the alternatives system. By default, the 3.x clients take precedence. The new clients also provide several bugfixes and leverage the latest VOMS Java APIs, as highlighted in the release notes. Starting with this release, the clients are also available on Maven Central;

 

Installation & Configuration:

Artifacts

SL5
Binaries
voms-2.0.12-2.el5.i386.rpm
voms-2.0.12-2.x86_64.rpm
voms-api-java3-3.0.4-1.sl5.noarch.rpm
voms-api-java3-javadoc-3.0.4-1.sl5.noarch.rpm
voms-clients-2.0.12-2.x86_64.rpm
voms-clients3-3.0.5-1.sl5.noarch.rpm
voms-debuginfo-2.0.12-2.x86_64.rpm
voms-devel-2.0.12-2.el5.i386.rpm
voms-devel-2.0.12-2.x86_64.rpm
voms-doc-2.0.12-2.x86_64.rpm
Source RPM
voms-2.0.12-2.el5.src.rpm
SL6
Binaries
voms-2.0.12-2.el6.i686.rpm
voms-2.0.12-2.el6.x86_64.rpm
voms-api-java3-3.0.4-1.sl6.noarch.rpm
voms-api-java3-javadoc-3.0.4-1.sl6.noarch.rpm
voms-clients-2.0.12-2.el6.x86_64.rpm
voms-clients3-3.0.5-1.el6.noarch.rpm
voms-debuginfo-2.0.12-2.el6.x86_64.rpm
voms-devel-2.0.12-2.el6.i686.rpm
voms-devel-2.0.12-2.el6.x86_64.rpm
voms-doc-2.0.12-2.el6.noarch.rpm
Source RPM
voms-2.0.12-2.el6.src.rpm

 

VOMS server, v. 2.0.12 & VOMS-admin server, v. 3.3.1

Affected services

  • affected services: VOMS server

What's new:

  • VOMS-Admin server 3.3.1 provides support for the configurable selection of enabled SSL protocols and cipher suites. VOMS-Admin v. 3.3.0 disabled SSL3 by default, but we have found out that mkgridmap clients would stop working with that setting. This version does not disable SSLv3 by default, but provides the ability to do it at a later time by changing a configuration parameter.
  • VOMS-Admin server 3.3.0 provides bugfixes and improvements in the integration with the CERN Organizational Database
  • VOMS server 2.0.12-2 fixes a problem in the RPM packaging that prevented mock builds to behave correctly.
  • VOMS server 2.0.12 which provides several bugfixes. In particular, some segfaults have been resolved and the server now correctly throttles incoming requests

Installation & Configuration:

Artifacts

SL5
Binaries
voms-admin-client-2.0.19-1.noarch.rpm
voms-admin-server-3.3.1-1.noarch.rpm
voms-mysql-plugin-3.1.6-1.x86_64.rpm
voms-mysql-plugin-debuginfo-3.1.6-1.x86_64.rpm
voms-oracle-plugin-3.1.15-2.x86_64.rpm
voms-oracle-plugin-debuginfo-3.1.15-2.x86_64.rpm
voms-server-2.0.12-2.x86_64.rpm
SL6
Binaries
voms-admin-client-2.0.19-1.el6.noarch.rpm
voms-admin-server-3.3.1-1.el6.noarch.rpm
voms-mysql-plugin-3.1.6-1.el6.x86_64.rpm
voms-mysql-plugin-debuginfo-3.1.6-1.el6.x86_64.rpm
voms-oracle-plugin-3.1.15-2.el6.x86_64.rpm
voms-oracle-plugin-debuginfo-3.1.15-2.el6.x86_64.rpm
voms-server-2.0.12-2.el6.x86_64.rpm

 

WMS Server v. 3.6.6-2

Affected services

  • affected services: WMS

What's new:

  • This is a rebuild of WMS-ICE with the new major version of MyProxy (v. 6)

Installation & Configuration:

  • Just update package, no reconfiguration is needed:
    		#yum update glite-wms-ice

Artifacts

SL5
Binaries
glite-wms-ice-3.5.4-2.sl5.x86_64.rpm
Source RPM
glite-wms-ice-3.5.4-2.sl5.src.rpm
SL6
Binaries
glite-wms-ice-3.5.4-2.sl6.x86_64.rpm
Source RPM
glite-wms-ice-3.5.4-2.sl6.src.rpm